RubyGems

RubyGems是Ruby上的套件管理工具,透過RubyGems我們可以很容易的呼叫命令去搜尋、安裝、與管理Ruby上的套件。若是安裝Ruby 1.9以後的版本,或是電腦中有安裝RVM的就會內建RubyGems可供使用,不然就要自行另外安裝。

安裝這邊若有需要可參閱Installing RubyGems或是函式庫 - Ruby

安裝完後,我們就可以開始使用RubyGems來做些動作。像是呼叫命令gem list,可以查閱在本地中安裝了那些Ruby的套件。

screenshot(95)

gem list -r命令可查閱RubyGems有提供那些套件可供安裝。

gem list -r [package name] (e.x. gem list -r vagrant)命令可查閱RubyGems是否有提供指定的套件可供安裝。

screenshot(99)

gem list -ra [package name] (e.x. gem list -ra vagrant)命令可進一步查閱RubyGems提供的指定套件有哪些版本可供安裝,而不是像gem list -r [package name]命令這樣只秀出最新的版本,當有需要找尋是否提供舊版套件時可以叫用。

screenshot(100)

gem install [package name] (e.x. gem install vagrant)命令可安裝指定的套件至本機系統中。

screenshot(94)

gem install -v [version] [package name] (e.x. gem install -v 1.0.6 vagrant)命令可安裝特定版本的指定套件至本機系統中。

screenshot(101)


gem uninstall [package name] (e.x. gem uninstall vagrant)命令可將指定套件至本機系統中移除。

screenshot(93)

gem update –system命令可更新本機所安裝的RubyGems版本。

screenshot(103)

gem cleanup命令可移除舊的或是重複安裝的RubyGems版本。

screenshot(102)

Link